Jump to content


Public support for Prestashop Pretty / Clean URLs PRO module. Ask about this module and get free public help.
Photo

internal server error 500 with pretty urls module

pretty urls

  • Please log in to reply
3 replies to this topic

#1 arun

arun

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 September 2021 - 10:32 AM

I have installed your module pretty urls and when I tried to click on configure, entire website stopped working. it is returning 500 internal server error after uploading this module. Please help me to fix this issue asap
 


#2 Milosz

Milosz

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts

Posted 13 September 2021 - 10:33 AM

Hello,
pretty clean urls module is available in 3 versions:
purls16.zip - for prestashop 1.6.x
purls17.zip - for prestashop 1.7.0.0 - 1.7.4.x
purls175.zip - for prestashop 1.7.5.0 - 1.7.7.x
 
do you used module version that is dedicated for your prestashop version?
if not - this is usually source of "internal server error 500".
 
if you acidentally uploaded and installed wrong version, you will need to remove this file: /overrides/classes/Dispatcher.php
then uninstall module in shop's back office with active option to "delete module files"
 
then, go to https://mypresta.eu/my-account/orders/ and download module in version that is dedicated for your prestashop version and install module in shop's back office
 
i offer my full support, if required.


#3 arun

arun

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 September 2021 - 01:04 PM

 

Hello,
pretty clean urls module is available in 3 versions:
purls16.zip - for prestashop 1.6.x
purls17.zip - for prestashop 1.7.0.0 - 1.7.4.x
purls175.zip - for prestashop 1.7.5.0 - 1.7.7.x
 
do you used module version that is dedicated for your prestashop version?
if not - this is usually source of "internal server error 500".
 
if you acidentally uploaded and installed wrong version, you will need to remove this file: /overrides/classes/Dispatcher.php
then uninstall module in shop's back office with active option to "delete module files"
 
then, go to https://mypresta.eu/my-account/orders/ and download module in version that is dedicated for your prestashop version and install module in shop's back office
 
i offer my full support, if required.

 

You were absolutely right. I have configured another version which is not compatible. As per your suggestion I have removed dispatcher.php and my website was back online. I have installed correct version and followed your documentation,  updated accordingly and it works fine for me. It does the job and thank you so much for immediate resolution. 



#4 waiking

waiking

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 26 September 2021 - 12:37 PM

i been sent you few tickets about the module problems. but never got a response...

 

 

 

the problem is after installed the module, the brand and supplier in the module can change to 

 

supplier/{rewrite}/

brand/{rewrite}/

see this

Screenshot 2021-09-26 202849.jpg

 

but the admin SEO/URLs

 

Route to supplier and Route to brand are not updated, still

supplier/{id}-{rewrite}

brand/{id}-{rewrite}

see this

Screenshot 2021-09-26 202717.jpg

 

when tried to update ,got this error

 

see this 

Screenshot 2021-09-26 202735.jpg

 

so, we cant activate both brand and supplier

 

at least give some advice and opinion about this.

 

 

 

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users